Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#922 closed defect (fixed)

Dimming problems

Reported by: rhn Owned by: dos
Priority: minor Milestone:
Component: SHR config Version: SHR-testing
Keywords: Cc:

Description

<copied from my mail on shr-user, adjusted due to new research>
In some cases, using the phone irregularly causes the screen to get stuck in the half-lit mode. After a while, it dims again and has to be reset manually.
Once the screen blanked completely, possibly because of the same reason.

Change History (10)

comment:1 Changed 8 years ago by elisa42

I saved some DEBUG logs of phonefsod awhile ago. I wasn't abel to reproduce the thing with it going totaly blank and not becoming lit again by touching it. It's some weired behaviour.. Sometimes when you touch the screen whhile it's dimmed on the first step it would become lit again though insted of 80 it would be 79 and so on..
Here's the log while i was playing around. http://pastebin.com/mcc2686c
This seems only to be reproduceable when the cpu load ist high. Like while intone is running and some webbrowsing or pidginuse is going on.
In the latest verion von phonefsod i wasn't able to get anything written in the log file while in DEBUG mode though the problem is still there.

comment:2 Changed 8 years ago by elisa42

I forgot to say. It's "_dimit: reference = 80" you got to look at. It's going down steadily.

comment:3 Changed 8 years ago by rhn

The screen becomes black and unresponsive only with high CPU usage.
It happened already several times today during compiling. After a few minutes after touching SHR-Today screen appears, but that's about it.

I ran
nice -n 19 make
but it didn't help, and I have to restart the phone using a long POWER button press.

comment:4 Changed 8 years ago by elhennig

Did you try to login to the FR and run

echo 150 >/sys/class/backlight/gta02-bl/brightness

comment:5 Changed 8 years ago by elisa42

i usually just restart phonefsod, which sets backlight back to 80%? and everything works again. But this is of course only possible while having another pc at hand..

comment:6 Changed 8 years ago by Heinervdm

  • Milestone set to MS1

comment:7 Changed 8 years ago by mrmoku

  • Resolution set to fixed in unstable
  • Status changed from new to closed

phonefsod does not try to magically adjust brightness anymore. Should be already fixed in shr-unstable.

comment:8 Changed 7 years ago by jama

  • Resolution fixed in unstable deleted
  • Status changed from closed to reopened

comment:9 Changed 7 years ago by jama

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:10 Changed 6 years ago by morphis

  • Milestone MS1 deleted

Milestone MS1 deleted

Note: See TracTickets for help on using tickets.