Opened 10 years ago

Closed 9 years ago

#852 closed defect (worksforme)

Odd behaviour with on-screen keyboard and midori

Reported by: ThibG Owned by: ainulindale
Priority: major Milestone: wishlist
Component: SHR Image Version: SHR-unstable
Keywords: Cc:

Description

Midori has an odd behaviour that makes it a pain to use:
When entering some text into the address bar using on-screen keyboard, and a list/menu pops up under the address bar, the entered keys are not what they should be, but the last key pressed before the menu pops.
This results in having to click the keyboard, then dismiss the menu by clicking in the adress bar, then clicking again the keyboard, etc. to enter a location.

Change History (7)

comment:1 Changed 10 years ago by apoapo

I can confirm this. This makes midori senseless.

comment:2 Changed 10 years ago by Heinervdm

Someone needs to investigate if it's gtk's fault or illume fault.
We can't tell the midori guys that there is an odd behavior on the FR, because they have no chance to reproduce it...

comment:3 Changed 10 years ago by jeremy-list

It's partially fixed now, the character typed on illume keyboard is now always the character that actually appears. But sometimes the history menu pops up over illume keyboard right when I'm about to press a button and suddenly I'm downloading something completely different and I've lost the partial url I'd already typed.

comment:4 Changed 10 years ago by Heinervdm

  • Milestone set to wishlist

comment:5 Changed 9 years ago by GNUtoo

  • Resolution set to fixed in unstable
  • Status changed from new to closed

it seem to work for me now,
if it doesn't work for you, reopen the bug.
Denis.

comment:6 Changed 9 years ago by Heinervdm

  • Resolution fixed in unstable deleted
  • Status changed from closed to reopened

comment:7 Changed 9 years ago by Heinervdm

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.