Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#851 closed defect (wontfix)

Mokonnect is not reliable

Reported by: ThibG Owned by: ainulindale
Priority: major Milestone:
Component: SHR Image Version: SHR-unstable
Keywords: Cc:

Description

I'm using SHR unstable on my GTA02A7 for a little more than a week, and I kept it up do date.
However, Mokonnect seems not to be reliable at all: most of the time, it'll not even see wireless networks, resulting in empty scans, or timeouts when trying to connect.
I've tried with two wireless networks, at different places.
One is open, and works fine with just turning wifi manually on, iwconfig eth0 essid OpenWrt? && udhcpc,
and the other is WPA-protected, works fine with a manual call to wpa_supplicant.
Both networks broadcast their ssid, and are shown by iwlist scan.

Change History (8)

comment:1 Changed 10 years ago by apoapo

I can confirm this. Mokonnect does not find any wireless 95% of time.. wpa_supplicant works fine. When a wifi is found, one has a chance of about 30% that it fails to get the DHCP lease.

comment:2 Changed 10 years ago by Tinker

The same goes for me, except I do not know how to connect using the terminal (yet).
Mokonnect almost never finds any networks, and if I enter the SSID manually it says it's not visible and "triggers scan" for 30 seconds. On a rear occasion it finds my network and reaches the timeout after failing DHCP configuration.
This is especially annoying because it prevents me from installing new packages and using the greatest tool in history, Internet.

comment:3 Changed 10 years ago by Airon90

I can get connect with Hotel Wiki but I cannot with Mokonnect

opkg remove mokonnect --force-depends
opkg install http://www.opkg.org/packages/hotelwifi_0.0.3_all.ipk

comment:4 Changed 10 years ago by Heinervdm

  • Milestone set to MS2

comment:5 Changed 9 years ago by GNUtoo

  • Resolution set to fixed in unstable
  • Status changed from new to closed

mokoconnect was removed from the default images, now there is iliwi.
please open a new bug if iliwi doesn't work for you.

Denis

comment:6 Changed 9 years ago by Heinervdm

  • Resolution fixed in unstable deleted
  • Status changed from closed to reopened

comment:7 Changed 9 years ago by Heinervdm

  • Resolution set to wontfix
  • Status changed from reopened to closed

comment:8 Changed 8 years ago by morphis

  • Milestone MS2 deleted

Milestone MS2 deleted

Note: See TracTickets for help on using tickets.