Opened 9 years ago

Closed 8 years ago

#85 closed defect (fixed)

Vagalume is missing button icons

Reported by: Thor Owned by: quickdev
Priority: major Milestone:
Component: SHR Image Version:
Keywords: Cc:

Description

Vagalume seems to have icons in the /usr/share/vagalume/icons/hicolor/scalable/actions folder.
However it fails loading them with the following messages:
root@om-gta02 /etc/init.d $ DISPLAY=:0 vagalume

(vagalume:1551): Gtk-WARNING : Could not find the icon 'media-playback-start'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:

http://icon-theme.freedesktop.org/releases

(vagalume:1551): DEBUG: Creating GStreamer element mad: success
(vagalume:1551): DEBUG: Creating GStreamer element autoaudiosink: success

Only two of the 8 buttons have icons on them.

Attachments (1)

42b53ddba30bb066235649d75d4f96e6.png (26.8 KB) - added by Thor 9 years ago.

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by Thor

comment:1 Changed 9 years ago by furester

even installing hicolor-icon-theme with opkg and rebooting the device we can't see icons in vagalume, but we don't get error message anymore.

comment:2 Changed 9 years ago by mrmoku

after installing librsvg-2-gtk the icons appear and creating an index.theme the icons appear.

comment:3 Changed 9 years ago by mrmoku

  • Resolution set to fixed
  • Status changed from new to closed

added a patch to the shr-overlay - should be fixed with the next build

comment:4 follow-up: Changed 8 years ago by Thor

Did this patch got lost along the way to the testing image? Vagalume is not showing the correct icons with the latest image flashed. Can anyone else please confirm this?

comment:5 in reply to: ↑ 4 Changed 8 years ago by makito

  • Resolution fixed deleted
  • Status changed from closed to reopened

I can confirm this bug on my shr
cat /etc/shr-version:

Tag Name: mv-packages-to-recipes-pre
VERSION: 02fe96061411de095776edd314d9ae551e1b2f22
Branch: shr/import
Build Host: opmbuild
Time Stamp: Sun, 06 Sep 2009 16:34:21 +0200

comment:6 Changed 8 years ago by Heinervdm

Where do you have that image from?

comment:7 Changed 8 years ago by makito

I got it from
http://build.shr-project.org/shr-unstable/images/om-gta02/

Is this right? This is my first foray into the openmoko scene.

comment:8 Changed 8 years ago by Heinervdm

I was iritated by the Build Host. But i've seen that it's the normal one.

I just installed the package and the icons are shown.

What package version do you have installed?

comment:9 Changed 8 years ago by TAsn

It seems that this is fixed and makito is just using an old version.

comment:10 Changed 8 years ago by Thor

I can confirm this on a fresh install of the latest SHR-Unstable (shr/import) fetched from http://build.shr-project.org/tests/mrmoku/unstable/images/ with all the updates in place. This might be related to a patch set up for an older version of Vagalume that does not get applied for the latest version (just a thought).

comment:11 Changed 8 years ago by Thor

In order to make the icons work, you need to create a index.theme file inside your /usr/share/vagalume/icons/hicolor/ folder with the following contents:

[Icon Theme]
Name=Hicolor
Comment=Fallback icon theme
Hidden=true
Directories=scalable/actions                                                 

[scalable/actions]
MinSize=1
Size=128
MaxSize=256
Context=Actions
Type=Scalable 

It appears that this file is missing from the default install somehow. This might be just a workaround fix, but afaik it won't hurt anything else, so can someone please add this as a patch to the Vagalume bitbake recipe?

Thank you!

comment:12 Changed 8 years ago by Heinervdm

No, we can't update any recipe before next image is finished. And in the new version it's working without index.theme.

comment:13 Changed 8 years ago by TAsn

  • Resolution set to fixed
  • Status changed from reopened to closed

According to Heinervdm it's fixed in newer version.

comment:14 Changed 8 years ago by Thor

  • Resolution fixed deleted
  • Status changed from closed to reopened

Looks like Vagalume is missing the button icons again, in the latest (up to date) Unstable image just flashed on the phne, probably due to the theme change (to gry). Can anyone confirm this?

comment:15 Changed 8 years ago by Heinervdm

Installing hicolor-icon-theme should fix this issue.

I sent a patch to update vagalume to version 0.8.2 and added icon-hicolor-theme to the recommends.

comment:16 Changed 8 years ago by Heinervdm

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.