Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#848 closed defect (fixed)

Phone suspends while trying to register

Reported by: BillK Owned by: mrmoku
Priority: major Milestone:
Component: SHR Image Version: all
Keywords: Cc:

Description

Current shr-testing (Jan 4th, 2010) suspends while waiting for GSM registration. This means that unless you remember to wake the phone up and wait/check for registration before re-suspending, you miss calls.

Change History (9)

comment:1 Changed 8 years ago by davidfokkema

Confirmed Feb. 4, latest upgrades. Isn't it possible to just grap the CPU resource using FSO until registration is complete?

comment:2 Changed 8 years ago by jeremy-list

I have a script that usually recovers from a failed registration attempt (I suspect that some failed registration attempts are at least partially due to this bug), unfortunately it's on the microSD in my openmoko which was rendered unusable by losing wifi signal part-way through opkg upgrade. I will attach it tomorrow when everything's up and running again.

comment:3 Changed 8 years ago by TAsn

  • Owner changed from ainulindale to TAsn
  • Status changed from new to accepted

comment:4 Changed 8 years ago by Heinervdm

  • Milestone set to MS1

comment:5 Changed 8 years ago by mrmoku

  • Owner changed from TAsn to mrmoku
  • Version changed from SHR-testing to all

Fix for this is in my tree and will hit SHR-U when we switch to fsogsmd - which will be real soon hopefully.

comment:6 Changed 8 years ago by mrmoku

  • Resolution set to fixed in unstable
  • Status changed from accepted to closed

Fix hit the SHR-unstable feed. phonefsod rev for this is ab3c3f35fa0a438819120ffa74748ff493a385f9. Suspend is now disabled on phonefsod startup until it registered or until a configurable time passed. Configuration for this is in [gsm] inhibit_suspend_on_startup_time. Value is in seconds and default is 360.

comment:7 Changed 7 years ago by jama

  • Resolution fixed in unstable deleted
  • Status changed from closed to reopened

comment:8 Changed 7 years ago by jama

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:9 Changed 6 years ago by morphis

  • Milestone MS1 deleted

Milestone MS1 deleted

Note: See TracTickets for help on using tickets.