Opened 8 years ago

Closed 8 years ago

#693 closed enhancement (invalid)

SMS on SIM not shown

Reported by: glun Owned by: mrmoku
Priority: major Milestone:
Component: libframeworkd-phonegui-efl Version: SHR-unstable
Keywords: Cc:

Description

Any of the SMS on the SIM are shown in the Messages Dialouge.
Please let me know, how to help debug this.

Change History (9)

comment:1 follow-up: Changed 8 years ago by Heinervdm

  • Component changed from SHR Image to libframeworkd-phonegui-efl
  • Owner changed from ainulindale to mrmoku
  • Priority changed from critical to minor
  • Type changed from defect to enhancement

What's wrong with showing all messages?

If you don't won't to display sent messages saved by another phone, this is an enhancement. And I think that's solved in phoneuid.

comment:2 follow-up: Changed 8 years ago by TAsn

  • Resolution set to invalid
  • Status changed from new to closed

I don't quite get what you mean, but I think you meant you *do* see sms that are stored on sim, which is a feature, not a bug.
feel free to remove the sim backend from shr-settings -> other -> opimd -> messages -> fso-sim
Though that'll will only work after the new untsable image.

comment:3 in reply to: ↑ 2 Changed 8 years ago by glun

  • Priority changed from minor to critical
  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to TAsn:

I don't quite get what you mean, but I think you meant you *do* see sms that are stored on sim,

No, as i wrote, i don't see any messages.
But i've to precise. New messages are shown.

feel free to remove the sim backend from shr-setting

My goal is to be able to see all the messages on the sim, not to remove anything.

comment:4 in reply to: ↑ 1 Changed 8 years ago by glun

Replying to Heinervdm:

What's wrong with showing all messages?

Nothing is shown, just newly arrived messages.

If you don't won't to display sent messages saved by another phone, this is an enhancement.

I don't speek about sent messages, i speek about received.
But anyway, it would be nice to be able to see sent messages as well.

comment:5 Changed 8 years ago by Heinervdm

Ah ok, now i got what you want.

Now please tell us, can you verify with another phone that there are SMS on the SIM card?
What message dialog do you use? shr-messages with libframeworkd-phonegui-efl?
Which opimd backend is configured for messages?
Can you see sth in frameworkd.log?

comment:6 follow-up: Changed 8 years ago by TAsn

Heinervdm, I think he's using libphone-ui/efl2 and haven't set opimd to use SQLite backend. This may be an issue (opimd has a bug) that he'll only see them after a reboot.
glun, is this correct?

comment:7 in reply to: ↑ 6 Changed 8 years ago by glun

The problem seems to be a bit different.
All the messages on the sim were deleted when switching from qtmoko-debian-v14 to shr-full-glibc-ipk--20090906-om-gta02. Whoever is responsible for that.
I used the dafault sms app of this image.

comment:8 Changed 8 years ago by mrmoku

I don't know anything about qtmoko... but I can imagine it might just store the messages not on the SIM... Possible?

comment:9 Changed 8 years ago by TAsn

  • Resolution set to invalid
  • Status changed from reopened to closed

according to the message by glun, it's invalid.

Note: See TracTickets for help on using tickets.