Opened 8 years ago

Closed 8 years ago

#686 closed defect (fixed)

E-Suspend-Button does Shutdown

Reported by: elhennig Owned by: ainulindale
Priority: major Milestone:
Component: Other Version: SHR-custom-builds
Keywords: Cc:

Description

If I use the suspend button in enlightenment/illume or via power button, the freerunner does not suspend, but shuts down to halt.

Another thing that I found was that resume only works every second wake up try.

I am using the latest mrmoku testing image (10/23/2009 20:16)

Attachments (1)

snip.frameworkd.log (4.3 KB) - added by catholicon 8 years ago.
Snip of frameworkd.log with log_level=DEBUG for oeventsd

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by Heinervdm

You know that resume still needs 6-8 seconds?
So can it be that you think you need two tries to wake up the device because of that?

comment:2 Changed 8 years ago by elhennig

Yes of course I know, I already mentioned that in ticket #673.

Right now the FR wakes up on resume and falls back to suspend immediately afterwards. The second resume is successful.

comment:3 Changed 8 years ago by elhennig

The behaviour is only there when usb is not cconnected

comment:4 Changed 8 years ago by elhennig

I think I located the problem: In illume/enlightenment settings there was the key xf86Power defined to do a power off after 2 secs but it started the shutdown immediately.

I remove the enlightenment settings under ~/.e and try again...

Changed 8 years ago by catholicon

Snip of frameworkd.log with log_level=DEBUG for oeventsd

comment:5 Changed 8 years ago by catholicon

I am facing second issue (phone suspends almost immediately after resuming...second resume works fine).
Deleting .e didn't help.

I think oevents takes care of suspend, so I have attached a snip of log with log_level=DEBUG for oeventsd.
In the log file, 2009.11.02 03:41:10.169 to 2009.11.02 03:41:16.178 is the duration when phone resumed and slept almost immediately.

comment:6 Changed 8 years ago by catholicon

okay, i've found the issue here (at least for me). I usually use litephone as the
telephony application and hence keep ophonekitd out of /etc/X/Xsession.d.

A week back I needed ophonekitd, so I'd put it back and the issue started (that the phone would sleep immediately after resume). Previously, I had posted that the issue didn't occur for calls; but its there for calls as well...just that as the incoming call continues, the phone wakes up again.

I removed opohekitd, and the issue is gone.

Although, I guess having 2 telephony apps is not really and intended thing (that is why I removed ophonekitd...I didn't like the various ophonekitd's windows popping up)....but then is this not why FSO is there as the interface; so that we can (if need be) have multiple telephony apps?

I am still unsure of the root cause...and have no real means to debug as well. Please tell me how to enable logging (and for which component)

comment:7 Changed 8 years ago by TAsn

  • Resolution set to fixed
  • Status changed from new to closed

We dropped ophonekitd, and auto suspend from it's replacement, should be fixed now.

Note: See TracTickets for help on using tickets.