Ticket #664 (closed defect: upstream)

Opened 5 years ago

Last modified 4 years ago

/etc/localtime loves to set itself to GMT+4 with related(?) GSM problem

Reported by: vendion Owned by: ainulindale
Priority: major Milestone:
Component: SHR Image Version: SHR-unstable
Keywords: Cc:

Description

I have found 2 problems with SHR-Unstable up to date, one may be related to the first but I can't say for sure.

The first problem is with the timezone, after finding out that I was still using GMT+4 timezone (hard to tell because the clock keeps displaying the correct time) I change /etc/localtime to New_York because I live in the Eastern timezone. After doing that the date command shows that I am using the EST timezone, but the second I reboot the timezone goes back to GMT+4.

As for the second and maybe related issue every time I change the timezone and reboot my freerunner then it kills my GSM, I can go into the SHR setting and move the slider to the "On" position but when I close out of that window and open it back up the slider is back in the "Off" position. I have to reboot the phone again in order to get the GSM to work.

If these problems are already fixed in the updates that are not yet released then let me know and I can wait until they are.

Attachments

ophonekitd.log Download (6.0 KB) - added by vendion 4 years ago.
ophonekitd log
frameworkd.log Download (23.6 KB) - added by vendion 4 years ago.
New frameworkd.log

Change History

comment:1 Changed 5 years ago by PaulFertser

/etc/localtime can be changed only by frameworkd guessing your timezone based on what operator you use. Please check your frameworkd log and try zonesources = NONE setting.

As to the second question i'd flag it as invalid even because you do not provide any relevant logs :-/

comment:2 Changed 5 years ago by vendion

2009.10.12 11:43:00.731 ogsmd.device         INFO     org.freesmartphone.GSM.Network.Status: {'
strength': 64, 'cid': u'22A7', 'registration': 'home', 'lac': u'09B8', 'act': 'GSM', 'code': u'
31026', 'mode': 'automatic', 'provider': u'T-Mobile'}
2009.10.12 11:43:01.82 otimed               INFO     GSM: timezone 'Etc/GMT+4'
2009.10.12 11:43:47.8 otimed               INFO     offsets: n=1 mean=31.552233 sd=0.000000
2009.10.12 11:43:47.20 otimed               INFO     adjusting clock by 31.552233 seconds
2009.10.12 11:44:19.103 odeviced.kernel26    INFO     capacity now 90

That is not right my provider is T-Mobile but my timezone is not GMT+4.

Where do I need to edit to set the zonesources = NONE setting and what log files do you need for the second problem?

comment:3 Changed 5 years ago by vendion

Setting it in /etc/frameworkd.conf didn't make the difference it still is set to GMT+4 even though I did a "ln -sf /usr/share/zoneinfo/America/New_York /etc/localtime" before a reboot

Changed 4 years ago by vendion

ophonekitd log

comment:4 Changed 4 years ago by vendion

This problem also affects the time change with Daylight savings. Now my phone is a hour ahead of the correct time, considering it thinks I am somewhere where it is GMT+4 instead of EST-5 it should be more if it was using timezones correctly.

comment:5 Changed 4 years ago by TAsn

  • Status changed from new to closed
  • Resolution set to fixed

It seems that this was an issue with missing tzdata packages, now fixed.

comment:6 follow-up: ↓ 7 Changed 4 years ago by vendion

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am still having this problem with

root@om-gta02 ~ $ cat /etc/shr-version
Tag Name: pre-nov2009-core-updates
VERSION: 214ca5592a29f4040c19711ad3ea1685cd238251
Branch: shr/merge
Build Host: opmbuild
Time Stamp: Fri, 20 Nov 2009 09:07:30 +0100
(note just ran opkg update && opkg upgrade)

According to my FreeRunning? the date is
root@om-gta02 ~ $ date
Sat Nov 28 05:29:06 GMT 2009

But according to my desktop which is right
vendion@Big-O:~> date
Sat Nov 28 00:29:32 EST 2009

comment:7 in reply to: ↑ 6 Changed 4 years ago by vendion

Replying to vendion:

I am still having this problem with

root@om-gta02 ~ $ cat /etc/shr-version
Tag Name: pre-nov2009-core-updates
VERSION: 214ca5592a29f4040c19711ad3ea1685cd238251
Branch: shr/merge
Build Host: opmbuild
Time Stamp: Fri, 20 Nov 2009 09:07:30 +0100
(note just ran opkg update && opkg upgrade)

According to my FreeRunning? the date is
root@om-gta02 ~ $ date
Sat Nov 28 05:29:06 GMT 2009

But according to my desktop which is right
vendion@Big-O:~> date
Sat Nov 28 00:29:32 EST 2009

Edit sorry about the typo FreeRunner? instead of FreeRunning?

comment:8 Changed 4 years ago by TAsn

You are using a custom built image, aren't you? I think the problem is with *your* build.

Anyhow,o reinstall the tzdata package and attach frameworkd.log please.

comment:9 Changed 4 years ago by vendion

No I'm using the 20091120 image I got from here  http://build.shr-project.org/shr-unstable/images/om-gta02/

I forced a reinstall of tzdata and tzdata-americas,

Changed 4 years ago by vendion

New frameworkd.log

comment:10 Changed 4 years ago by TAsn

INFO GSM: multiple zones found
hm.. it seems that the framework does not know what to set your timezone to, please ask in freesmartphone.org as it's an upstream issue, we fixed the missing packages part, this looks like a software issue (FSO).

comment:11 Changed 4 years ago by vendion

I opened a bug report with FreeSmartPhone?, here is a link for tracking if needed  http://trac.freesmartphone.org/ticket/496

comment:12 Changed 4 years ago by TAsn

  • Status changed from reopened to closed
  • Resolution set to upstream

cool, closing this as upstream.

Note: See TracTickets for help on using tickets.