Opened 8 years ago

Closed 8 years ago

#608 closed defect (fixed)

WiFi doesn't work after resume in Aug-23 upgrade

Reported by: vendion Owned by: ainulindale
Priority: major Milestone:
Component: SHR Image Version: SHR-unstable
Keywords: Cc:

Description

After upgrading on the 23 I have found that mokonnect is able to connect to wireless networks again, which is a good thing, but after resuming from the suspend state the wireless network is not reconnected to. Manually trying to reconnect I see this error "WiFi? device can not be powered on or is not visible to connman" thinking it was a Connman error I restarted the daemon but still got the same error. After checking the WiFi? status in SHR-Settings I found the slider for the card was in the off position and every time I tried to turn it on it would go back to off.

Change History (5)

comment:1 Changed 8 years ago by TAsn

Does it still happen?

comment:2 Changed 8 years ago by vendion

With latest updates to SHR yes it I still do experience this issue

comment:3 Changed 8 years ago by TAsn

And now? we now use both fsodeviced and fsousaged, and I think that should fix it.

What do you say?

comment:4 Changed 8 years ago by vendion

Yes that fixes the problem, now I just have a problem with mokonnect where when it exits it kills connman. So in order to reconnect I have to start connman back up then open up mokonnect and keep it open.

comment:5 Changed 8 years ago by TAsn

  • Resolution set to fixed
  • Status changed from new to closed

mokonnect *should* stay open whenever you use wifi (unless you explicitly turned it on through shr-settings).

Anyhow, It's fixed, closing.

Note: See TracTickets for help on using tickets.