Opened 8 years ago

Closed 8 years ago

#533 closed defect (wontfix)

erminig unusable

Reported by: crueb Owned by: ainulindale
Priority: major Milestone:
Component: Feed packages Version: SHR-unstable
Keywords: Cc:

Description

As requested in #507 erminig is now in the repo, but when extracting the archives the paths seem wrong (e.g. erminig executable is not in /usr/bin).
Interpreter is python2.5 which is not available and dependencies are missing (e.g. hildon, which should be somewhere in the maemo packages).

In the current state erminig is unusable but it would be really nice to have a sync possibility for gpe-calendar (best calendar app for Freerunner so far IMHO).

It would be nice if someone could deal with this case - I provide help where I can.

Change History (5)

comment:1 Changed 8 years ago by spaetz

Our recipe is here: http://cgit.openembedded.org/cgit.cgi/openembedded/tree/recipes/erminig/erminig_3.0.3.bb?h=shr/import

All we are doing is calling the stock Makefile as provided by upstream. Looking at their sourcecode, it seems they have hardcoded python2.5 all over the place in their source, which would be very cumbersome to patch from our side.

The best approach is to contact the upstream authors and make them change their makefiles and setup code to be more generic, ie to accept /usr/bin/env python or just "python" or whatever as interpreter. I certainly don't want to play find and replace with every release of erminig.

comment:2 Changed 8 years ago by crueb

I had a look around and PyMaemo? is still on Python 2.5 which might be the reason why the apps are also using 2.5.

Currently there is an ongoing discussion when to migrate to python 2.6 here:
http://wiki.maemo.org/PyMaemo/Python26PortingGuide

I'll try to build python-hildon and erminig for SHR and see if it works. I'll let you know my results.

comment:3 Changed 8 years ago by crueb

I have now been poking around with this stuff for a while but with little success:
I tried to build python-hildon and created a bb recipe but it does not even get to the point to build it as dependencies fail to build (e.g. libhildonfm which seems not to build anymore with GTK >= 2.14). Also I had to fix the libhildonmime to build at all.

I think it would be best to wait for a real OE integration (see here: http://www.cse.iitm.ac.in/~rkirti/maemo-oe/).

Until now there would be too many things to fix until all this would work and I do not have time for that.

So you may close the ticket unless someone else has more success with this, but the initial title stays true - without python-hildon erminig is unusable...

comment:4 Changed 8 years ago by dos

  • Component changed from SHR git to SHR Feed

comment:5 Changed 8 years ago by spaetz

  • Resolution set to wontfix
  • Status changed from new to closed

Closing per reporters suggestion. Do reopen this once it is in a usable state.

Note: See TracTickets for help on using tickets.