Ticket #529 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

No package for python gzip module

Reported by: novalis Owned by: ainulindale
Priority: major Milestone:
Component: SHR Image Version: SHR-unstable
Keywords: Cc:

Description

Python on the openmoko is pretty heinously broken, because modules that are supposed to be part of core are broken out into separate packages. There is no way for third-party python programs to know that they're on a shr system and thus have to instruct the user to install various packages -- python programs by convention assume that the core python libraries are available.

Also, apparently, the gzip module is not part of any of these packages.

Change History

comment:1 Changed 5 years ago by spaetz

  • Status changed from new to closed
  • Resolution set to invalid

Yes, python is being installed in a reduced form, not including all of the standard library. E.g. the GTA01 is being squeezed for space already, so we cannot include the kitchensink by default, unfortunately. They way this is supposed to be handled is that the recipe for an application includes the necessary dependencies, so all required packages are available when you need then. So what you should do is to ask for a python-gzip dependency for a specific application that requires and and it will be added to that app's recipe.

HTH

Note: See TracTickets for help on using tickets.