Ticket #492 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

opimd is crashing frameworkd when trying to combine messages

Reported by: KaZeR Owned by: dos
Priority: blocker Milestone:
Component: Frameworkd / FSO Version:
Keywords: Cc:

Description

Now messages segfaults right when starting.

Attachments

frameworkd.log Download (36.4 KB) - added by KaZeR 5 years ago.
ophonekitd.log Download (7.2 KB) - added by KaZeR 5 years ago.
frameworkd.2.log Download (280.3 KB) - added by KaZeR 5 years ago.
ophonekitd.2.log Download (7.4 KB) - added by KaZeR 5 years ago.
frameworkd.3.log Download (280.4 KB) - added by KaZeR 5 years ago.
ophonekitd.3.log Download (7.5 KB) - added by KaZeR 5 years ago.
frameworkd.4.log Download (242.1 KB) - added by KaZeR 5 years ago.
ophonekitd.4.log Download (5.0 KB) - added by KaZeR 5 years ago.
frameworkd.5.log Download (245.4 KB) - added by KaZeR 5 years ago.
ophonekitd.5.log Download (4.7 KB) - added by KaZeR 5 years ago.
frameworkd-info.log Download (33.0 KB) - added by KaZeR 5 years ago.
frameworkd-info.2.log Download (31.8 KB) - added by KaZeR 5 years ago.

Change History

Changed 5 years ago by KaZeR

Changed 5 years ago by KaZeR

Changed 5 years ago by KaZeR

Changed 5 years ago by KaZeR

Changed 5 years ago by KaZeR

Changed 5 years ago by KaZeR

comment:1 Changed 5 years ago by KaZeR

With Ainuidale's help yesterday i was able to read my messages and place a few phone calls.

But today, it's a no go.

Yesterday's issue was caused by me trying to read messages too early : sim card was registered, and before contact cache it would have been a sufficient delay. Now, we have to wait a bit more.

I waited until an uptime of 5 minutes, and until nothing new showed up in frameworkd.log, last line was

2009.05.28 09:40:58.288 ogsmd.channel        DEBUG    <MiscChannel via /dev/pts/3>: COMPLETED 'AT+CPBS="SM";+CPBR=?' => ['+CPBR: (1-250),44,20', 'OK']

So i thought it was sufficient.

I tried to launch messages, it segfaulted right away :

root@om-gta02 ~ $ openmoko-messages
** (process:1565): DEBUG: Trying to get the system bus
** (process:1565): DEBUG: Adding signals.
** (process:1565): DEBUG: Entering ecore loop
** (process:1565): DEBUG: phonegui_messages_show()
** (process:1565): DEBUG: ogsmd_sim_retrieve_phonebook_callback()
** (process:1565): DEBUG: cache_phonebook_callback called
** (process:1565): DEBUG: caching phonebook failed: The name org.freesmartphone.ogsmd was not provided by any .service files dbus -1
** (process:1565): DEBUG: Initiated elementary
** (process:1565): DEBUG: Initiated etk
** (process:1565): DEBUG: event_callback()
** (process:1565): DEBUG: _show()
** (process:1565): DEBUG: window_init(win=76320)
** (process:1565): DEBUG: window_view_show()
** (process:1565): DEBUG: window_view_hide()
** (process:1565): DEBUG: message_list_view_show()
** (process:1565): DEBUG: tree init
** (process:1565): DEBUG: ogsmd_sim_retrieve_messagebook_callback()
** (process:1565): DEBUG: retrieve messagebook callback(error=290576)
Segmentation fault

After that, no phone call possible, no gprs access possible.

ophonekitd process is still alive.

Here are the logs, from boot to call try. (.4.log)

Changed 5 years ago by KaZeR

Changed 5 years ago by KaZeR

comment:2 Changed 5 years ago by daniel

It looks like ophonekitd is caching stuff nowadays?

Anyway, framework log looks good in my opinion. It looks like it returns contacts as well as messages.

comment:3 Changed 5 years ago by KaZeR

Indeed, there is now contact cache.

I made another try : booted the phone, waited 12 minutes.
Started openmoko-messages : segfault.

What can i do?

comment:4 Changed 5 years ago by KaZeR

I'm adding another batch of logs..5 are : boot, wait 7 or 8 minutes, try to connect to gprs using dbus. Result : Service name not found.

Changed 5 years ago by KaZeR

Changed 5 years ago by KaZeR

comment:5 Changed 5 years ago by KaZeR

root@om-gta02 ~ $ mdbus -s
:1.0
:1.1
:1.23
:1.24
:1.3
:1.4
:1.5
:1.6
:1.7
:1.8
:1.9
fi.epitest.hostap.WPASupplicant
org.bluez
org.freedesktop.Avahi
org.freedesktop.DBus
org.freedesktop.Hal
org.pyneo.muxer
org.shr.ophonekitd.Usage

No ogmsd??

comment:6 Changed 5 years ago by KaZeR

2009.05.28 10:49:20.655 opimd                ERROR    SIM-Contacts-FSO: Could not request SIM phonebook from ogsmd : org.freesmartphone.Resource.NotEnabled: Resource Device is not enabled, current status is 'unknown'

It looks like the cache is trying to load the datas too early, no? What is causing this?

comment:7 Changed 5 years ago by ainulindale

  • Status changed from new to accepted

The opimd error isn't a problem. The fact that you don't have the freesmartphone bus names is really a problem though, it means the framework either crashed or didn't start. Could you check?

comment:8 Changed 5 years ago by KaZeR

As requested per Arne Anka, new frameworkd logfile with log_level=INFO.

Scenario : booted, waited 4 minutes. I checked with mdbus -s, i had the ogsmd service. Tried to connect to gprs via dbus, and got :

ERROR:dbus.proxies:Introspect error on :1.13:/org/freesmartphone/GSM/Device: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
/org/freesmartphone/GSM/Device: ActivateContext failed: org.freedesktop.DBus.Error.ServiceUnknown

Now, i don't have osmgd service anymore..

Changed 5 years ago by KaZeR

comment:9 Changed 5 years ago by mrmoku

are you using libframeworkd-phonegui-efl2 - the opimd variant of our apps? If so, could you please check if the 'old' one works?

comment:10 Changed 5 years ago by KaZeR

In fact it doesn't crash because of use : it crashes after a given amount of time.
In frameworkd-info-2.log i booted the phone, and did nothing. It crashed between 12:04:09 and 12:05:16, after an uptime of 4 minutes.

@ mrmoku :

root@om-gta02 ~ $ opkg list_installed |grep -i phonegui |grep -v locale
libframeworkd-phonegui-efl0 - 0.0.2+gitr674+e128a5c74b766cbf5e5d2863bc322d1d3c942c70-r31 -
libframeworkd-phonegui0 - 0.0.2+gitr674+e128a5c74b766cbf5e5d2863bc322d1d3c942c70-r8 -

so i guess i'm using the old one?

Changed 5 years ago by KaZeR

comment:11 follow-up: ↓ 12 Changed 5 years ago by KaZeR

new fact : if i stop the framework, kill ophonekitd, and relaunch both of them, everything works (tested sms and gprs).
Some kind of race condition?

comment:12 in reply to: ↑ 11 Changed 5 years ago by BlackEdder

Replying to KaZeR:

new fact : if i stop the framework, kill ophonekitd, and relaunch both of them, everything works (tested sms and gprs).
Some kind of race condition?

Just wanted to add that I am experiencing the same issues (+ thanks for the workaround!). For me the problems started on monday and (looking at the packages dates) are likely to do with the frameworkd-* or config-shr updates.

Weirdly enough another SIM I own is working correctly.

comment:13 follow-up: ↓ 14 Changed 5 years ago by dos

  • Priority changed from major to critical
  • Version SHR-unstable deleted
  • Component changed from SHR Image to frameworkd / FSO
  • Summary changed from Unable to read sms. New issue? to frameworkd quits when trying to read messages

Can you run frameworkd from command line just using "frameworkd" command? And then try to repeat that issue and check, when frameworkd quits and with which error?

comment:14 in reply to: ↑ 13 ; follow-up: ↓ 15 Changed 5 years ago by BlackEdder

Replying to dos:

Can you run frameworkd from command line just using "frameworkd" command? And then try to repeat that issue and check, when frameworkd quits and with which error?

I get the following output:
root@om-gta02 ~ $ frameworkd
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning?: object.init() takes no parameters

super(Connection, self).init(*args, kwargs)

/usr/lib/python2.6/site-packages/framework/controller.py:147: Warning: gobject.io_add_watch callback returned None; should return True/False?

self.mainloop.run()

Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/framework/patterns/tasklet.py", line 178, in send

value = self.generator.send(value)

File "/usr/lib/python2.6/site-packages/framework/subsystems/opimd/pimb_sim_messages_fso.py", line 176, in load_entries

self.process_all_entries(entries)

File "/usr/lib/python2.6/site-packages/framework/subsystems/opimd/pimb_sim_messages_fso.py", line 161, in process_all_entries

self.process_spliten_entries(message)

File "/usr/lib/python2.6/site-packages/framework/subsystems/opimd/pimb_sim_messages_fso.py", line 127, in process_spliten_entries

last_msg[4]combined_message? = True

IndexError?: list index out of range

comment:15 in reply to: ↑ 14 Changed 5 years ago by dos

  • Owner changed from ainulindale to dos
  • Priority changed from critical to blocker
  • Summary changed from frameworkd quits when trying to read messages to opimd is crashing frameworkd when trying to combine messages

Replying to BlackEdder:

I get the following output:

Well, and that's correct log! It seems to be opimd issue, so it's my fault and i will fix it. Thanks for reporting ;)

It should be on FSO trac, but i'm lazy and I will use this ticket ;)

comment:16 Changed 5 years ago by dos

Ok, after looking at code: it fails when you have split messages in inbox, but you don't have last message (so for instance you have stored first and second message, but third didn't come due to full inbox). Fixing it now.

comment:17 Changed 5 years ago by dos

  • Status changed from accepted to closed
  • Resolution set to fixed

Ok, i think i've just fixed it in FSO git. Now you have to wait for package in feeds... or if you don't want to wait just apply that commit  http://git.freesmartphone.org/?p=framework.git;a=commitdiff;h=c35f6336015c0c672a832a83d76e33f276726f10 by hand ;)

If it still doesn't work, please reopen.

comment:18 Changed 5 years ago by KaZeR

That's what i call efficency :) Thank you.
I made some cleanup in my mbox before seeing your messages here, so i might have deleted the faulty messages. Anyway, i've applied the fix and so far it's working well.
Thanks!

comment:19 Changed 5 years ago by KaZeR

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:20 Changed 5 years ago by KaZeR

woops sorry.. didn't meant to reopen, was on the wrong tab

comment:21 Changed 5 years ago by dos

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.