Opened 9 years ago

Closed 8 years ago

#413 closed enhancement (duplicate)

display profile in use

Reported by: piratebab Owned by: ainulindale
Priority: minor Milestone:
Component: SHR Image Version: SHR-testing
Keywords: Cc:

Description

When a profile like "silent" is use (i.e during a meeting), it is very frequent to forget to switch back to "default".
So I suggest to display the profile in use on top left of the screen (replacing "illume" text)

Change History (4)

comment:1 Changed 8 years ago by Montgoss

The typical way I see this handled on other phones would be an icon at the top (as opposed to replacing text). When the ringer is silenced, a bell icon would appear cross-out.

Perhaps this would be a better approach. This icon could also be used as a quick-launch shortcut for the shr-settings profile selector (addressing ticket 411).

comment:2 Changed 8 years ago by spaetz

The illume text is set by illume and it will IMHO be mighty difficult to change it and abuse it for our purposes. We need to write a nicer GSM Gadget anyway, so perhaps we can overlay that with a crossed bell if we have a silent profile, or something like that.

Just asked on IRC, and replacing that string is not easily possible:

< spaetz> raster: someone proposed to replace the "illume" text in the 
                taskbar with the current profile name. how much is that text hard coded?
< raster> spaetz: 100% hard-coded
< raster> when no window is active it just pastes illume in there
< raster> (it could be blank - but i just chose to advertise)
< raster> :)
< spaetz> ok, thought so
< raster> there is no code that fetches that string from somewhere

comment:3 Changed 8 years ago by KaZeR

I'm interested in that too.

comment:4 Changed 8 years ago by dos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42

Note: See TracTickets for help on using tickets.