Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#411 closed enhancement (fixed)

Profiles selection

Reported by: piratebab Owned by: ainulindale
Priority: minor Milestone:
Component: SHR Image Version: SHR-testing
Keywords: Cc:

Description

In addition to ticket #410, an easy way to select a profile could be by pressing the AUX button for at least 2 sec.
A menu appears, and we select the profile ("meeting", "plane", ....)

Change History (10)

comment:1 Changed 8 years ago by dos

Use rules.yaml on some signals app to start that command:
shr-settings "Change profile" shr_profile.Profile shr_currentprofile.CurrentProfile?

comment:2 Changed 8 years ago by spaetz

alternatively install shr-config which launches a profile selector with 'settings -mProfiles'. create a key binding for the aux button and you are done...

comment:3 Changed 8 years ago by dos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #291

comment:4 Changed 8 years ago by njw

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I agree that this would be a very useful default to add.

Just a very simple setting so that on aux hold the command:

shr-settings Profile shr_profile.Profile

is triggered (love how easy that is to do, by the way!)

I couldn't tell from #291 if the best way of doing that is in rules.yaml or e.src.

comment:5 Changed 8 years ago by TAsn

We are already working it (a quick settings app) wait for updates.

comment:6 Changed 8 years ago by Heinervdm

  • Milestone set to MS1

comment:7 Changed 8 years ago by mrmoku

  • Resolution set to fixed in unstable
  • Status changed from reopened to closed

QuickSettings? is there and bound to the power key (at least in illume2). Profile switching works nicely there. The apropriate DBus call to show the quick settings is:
org.shr.phoneui /org/shr/phoneui/Settings org.shr.phoneui.Settings.DisplayQuickSettings?

comment:8 Changed 7 years ago by jama

  • Resolution fixed in unstable deleted
  • Status changed from closed to reopened

comment:9 Changed 7 years ago by jama

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:10 Changed 6 years ago by morphis

  • Milestone MS1 deleted

Milestone MS1 deleted

Note: See TracTickets for help on using tickets.