Opened 6 years ago

Last modified 5 years ago

#1849 accepted defect

Charging via usb cable does not work for gta04

Reported by: micvm Owned by: slyon
Priority: major Milestone:
Component: Other Version: SHR-core
Keywords: Cc:

Description

Charging the device through the usb cable does not work. Normal usb connection over cdc_ether works.

Change History (5)

comment:1 follow-up: Changed 6 years ago by slyon

this works for me. and worked always.
The indication in the illume top-bar isn't working though.

What status do you have in bq27000-battery while on usb?

root@om-gta04:~# cat /sys/class/power_supply/bq27000-battery/status 
Charging

comment:2 Changed 6 years ago by slyon

  • Owner changed from TAsn to slyon
  • Status changed from new to accepted

comment:3 in reply to: ↑ 1 Changed 6 years ago by micvm

Replying to slyon:

this works for me. and worked always.
The indication in the illume top-bar isn't working though.

What status do you have in bq27000-battery while on usb?

root@om-gta04:~# cat /sys/class/power_supply/bq27000-battery/status 
Charging

root@om-gta04:~# cat /sys/class/power_supply/bq27000-battery/status
Discharging

FYI I am using the latest shr-core labelled as stable, not the testing version. I reinstalled a second ago

comment:4 Changed 6 years ago by micvm

I installed the latest image from http://build.shr-project.org/shr-core-staging/latest/images/ and have still the same problem.

comment:5 Changed 5 years ago by slyon

Is this still valid with the latest kernel 3.4.9?
Unfortunately I cannot reproduce this problem..

Note: See TracTickets for help on using tickets.