Opened 7 years ago

Last modified 6 years ago

#1500 new defect

[shr-core] iliwi doesn't work with tkip

Reported by: robin Owned by: mrmoku
Priority: major Milestone:
Component: SHR Image Version: SHR-core
Keywords: Cc:

Description

connecting to wlan without encryption does work, using a tkip (which worked for unstable) results in connected but no traffic goes through

Change History (6)

comment:1 Changed 7 years ago by elisa42

does it work if you manualy turn wlan on in shr-settings before starting iliwi?

comment:2 Changed 7 years ago by robin

no luck turning wifi on manually beforehand ...

comment:3 Changed 7 years ago by elisa42

could you open the terminal and type iwconfig?
it probably says something like Bit Rate: 65.XXX Mb/s.

comment:4 Changed 7 years ago by robin

  • wifi turned on via settings
  • iwconfig

eth0 AR6000 802.11g ESSID:"XYZ"
Mode: Managed Frequency: 2.427 GHz Access POInt: 00:...:8A
Bit Rate = 24Mb/s Tx-Power=15 dBm Sensitivity=0/3
Retry:on
Encryption key:off (??? it certainly is tkip android and shr-unstable work!)
Power Management:off
Link Quality:187/94 Signal level:-164DBm Noise level:-96dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

-iliwi & results in CONNECTED (enc 30% signal strength)

-iwconfig now is teh same as above but with the bit rate set to 65.535Mb/s

comment:5 Changed 6 years ago by RuiSeabra

Did just that, but even though it did claim to be connected, it wouldn't ping my gateway. After a reboot, the process above described worked fine. Weird.

comment:6 Changed 6 years ago by elisa42

when iwconfig shows 65.535Mb/s and Tx-Power=0 dBm then you should just turn of wifi and try again. when this happens the wlan firmware ran into a dead end. turn wifi off and on and try again.

Note: See TracTickets for help on using tickets.