Ticket #136 (closed defect: invalid)

Opened 6 years ago

Last modified 5 years ago

keeping stylus on touchscreen doesn't reset/stop idle timer

Reported by: helge.hafting@… Owned by: ainulindale
Priority: minor Milestone:
Component: Frameworkd / FSO Version:
Keywords: Cc:

Description

I downloaded the game liquidwar from opkg.org.
This game is played using the touchscreen.

While playing, the screen suddenly dimmed the way it does when you haven't been using the phone for a while. Strange, because this game needs clicking/dragging all the time.

From then on, nothing helped. The game (and window manager and other apps) all reacted normally to clicks, but the backlight stayed dim, and then the phone suspended itself shortly after dimming.

I pressed the power button to wake it up. It woke up briefly and suspended again. A second press woke it up properly.

From then on, this became the pattern:
The phone suspended 30s or so after it woke up, no matter how actively I used it. (game or other use) Pressing the power button always woke it up briefly before going black again and then a second press gave me another 30s before the backlight dimmed and the phone suspended again.

It was as if it no longer saw touchscreen usage as reason enough to restart the suspend timeout. The situation persisted even though I quit the game.

The phone remained useable but unfriendly (wake it up every 30s...),

except that sound did not come back after the first mistaken suspend.

A working suspend is a very nice thing to have, but kind of annoying when it happens too much. I'll turn suspend off for now.

I don't know what the game did to get the phone into such an odd state.

Change History

comment:1 in reply to: ↑ description Changed 6 years ago by ainulindale

  • Status changed from new to accepted

Does it use pulseaudio?

comment:2 Changed 6 years ago by Montgoss

I am experiencing the same bug, but I did not play liquidwar. I think it is caused by some conflict between the settings app accessible from the launcher and the settings app accessed through the wrench icon in the top bar.

The behavior you were seeing with a press of the power button "woke it up briefly and then before going back to sleep" is actually this: the screen is blank but the phone is not suspended. Pressing the power button causes the display to come to full brightness for a split second before it enters suspend (since suspending is bound to the power button).
If you press the AUX button instead, the display will return to full brightness.

But something has caused touchscreen events to no longer reset the screen dim/blank timer.

comment:3 Changed 6 years ago by elisa42

I do too see this bug sometimes (feels like this bug shows up when using the touchscreen extensivly). When i did a /etc/init.d/frameworkd restart
everything was fine again and it stopped blanking the screen, while touching it.

comment:4 Changed 6 years ago by hafting

It is indeed related to heavy touchscreen use. I now see the same playing sudoku! A hard sudoku makes for some thinking, and I hate that the screen shut off while I think. So I keep the stylus on an unused part of the screen, sliding it slightly back and forth. This keeps the light on - until this bug happens.

My guess: Touching the screen resets the timer. Keeping the screen pressed until the timer times out wrecks the "bookkeeping" somehow.

The backlight timer should not run while the screen is being touched - and it may indeed be touched continously for several minutes in games. Resetting the timer on every drag/move is probably too heavy-handed. The lighter approach is to stop the timer when something touch the screen, and only start the timer again when the screen (eventually) is released.

Helge Hafting

comment:5 Changed 5 years ago by spaetz

  • Priority changed from major to minor
  • Component changed from SHR Image to framworkd / FSO
  • Summary changed from Play "liquidwar" and then touchscreen usage don't prevent suspend anymore to keeping stylus on touchscreen doesn't reset/stop idle timer

Adapting summary to fit the new info we have. This is bound to be an upstream frameworkd bug and should be filed there. I couldn't find an existing one yet so it should probably be filed on  http://trac.freesmartphone.org

comment:6 Changed 5 years ago by dos

  • Status changed from accepted to closed
  • Resolution set to invalid

 http://trac.freesmartphone.org/ticket/333

As there is ticket upstream, and it's not SHR problem - closing.

Note: See TracTickets for help on using tickets.