Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#1075 closed defect (fixed)

Sometimes Massages dont get noticed when received

Reported by: Hardy Owned by: mrmoku
Priority: major Milestone:
Component: shr-messages Version: SHR-unstable
Keywords: shr-massages, sms, notice Cc:

Description

After a received SMS sometimes shr-massages wouldnt show it up at the screen an give a signal tone. Also shr-today wouldnt merge received sms's in the unlock-screen. They´re just in the sms-libary...

anyone also noticed that fact of failed sms noticeing? ;)

Change History (14)

comment:1 Changed 8 years ago by TAsn

To be honest, I don't quite understand your report.
I got the signal tone part, and after thinking about it I realized what you meant in showing up on screen (my fault for not getting it, as I disabled it here). But what do you meuan about shr-today?
Please attach /var/log/phoneuid.log ? (make sure it doesn't include sensitive information first).

comment:2 Changed 8 years ago by badcloud

I can second this. sometimes on incoming sms', I only hear the chime but the message does not appear without me *going* into messages and picking it out from the others. occasionally the lock screen does not update to display that there is one unread message either

hope this helps

comment:3 follow-ups: Changed 8 years ago by mrmoku

does this still happen?

comment:4 in reply to: ↑ 3 Changed 8 years ago by badcloud

Replying to mrmoku:

does this still happen?

cannot be of help at the moment, since I am using qtmoko at the moment

sorry

comment:5 in reply to: ↑ 3 Changed 8 years ago by badcloud

Replying to mrmoku:

does this still happen?

ok. installed full-om-gta02.tar.gz (unstable May 19th)

same thing. missed calls are shown on lock screen but not new messages

comment:6 Changed 8 years ago by mrmoku

do you have automatic showing of messages enabled? show_incoming_sms=true in /etc/phonefsod.conf?
If so, then messages won't be shown in IdleScreen?... as they're automatically seen.

comment:7 Changed 8 years ago by badcloud

'show_incoming_sms' is '=true' in /etc/phonefsod.conf

the thing is, the message doesn't even come into the foreground automatically unless device came out of suspend (due to incoming msg). the same goes for idle screen msg notification

comment:8 follow-up: Changed 8 years ago by mrmoku

well... we could deactivate the IdleScreen? lock on an incoming message... but I'm quite sure this is not wanted either. Imagine the phone in your pocket doing funny things just because it woke up and deactivated the IdleScreen? for an incoming message.

The correct thing to do probably would be to mark the message as read only when the message window was actively in the foreground. Dunno how to do that though :/

comment:9 in reply to: ↑ 8 Changed 8 years ago by badcloud

Replying to mrmoku:

well... we could deactivate the IdleScreen? lock on an incoming message... but I'm quite sure this is not wanted either. Imagine the phone in your pocket doing funny things just because it woke up and deactivated the IdleScreen? for an incoming message.

The correct thing to do probably would be to mark the message as read only when the message window was actively in the foreground. Dunno how to do that though :/

I don't think you quite understand what I meant

if device is on, incoming message does not come into the foreground. it does when device came out of suspend (due to incoming msg). idle screen also does not seem to update to incoming msg

I think this have something to do with the 'messages' program being in the background (can't reproduce because I'm using qtmoko as daily phone)

comment:10 Changed 8 years ago by jeremy-list

I probably figured out the reason for this problem: phoneui often closes all windows about 1 second after recieving or sending an sms (it's more frequent when you have a lot of saved messages). This marks the message as read even though it's never actually shown the message on the screen or only shown it for a second or less before closing itself.

comment:11 Changed 8 years ago by dos

  • Resolution set to fixed in unstable
  • Status changed from new to closed

Closing all windows happens, when phoneuid segfaults :P

Anyway, phoneuid should be much more stable now. Please reopen, if it still happens.

comment:12 Changed 7 years ago by jama

  • Resolution fixed in unstable deleted
  • Status changed from closed to reopened

comment:13 Changed 7 years ago by jama

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:14 Changed 6 years ago by morphis

  • Milestone MS1 deleted

Milestone MS1 deleted

Note: See TracTickets for help on using tickets.